さくらのレンタルサーバーの freebsd バージョン古い

os

wordpress の管理画面に

「お使いの php バージョンが古いので更新してください」

と出たので調査してみました。

$ uname -a
www1564.sakura.ne.jp
FreeBSD 9.1-RELEASE-p24 #0: Thu Feb  5 10:03:29 JST 2015 amd64
$ php -v
PHP 5.6.40 (cli) (built: Jan 17 2019 21:42:57) 

2022年2月時点でめちゃ古い!

以下のように FreeBSD 9.x系から11.x系にアップデートされたようです。

ただ、私の www1564.sakura.ne.jp は対象外のようです。

さくらのレンタルサーバ FreeBSDのアップデートに伴う変更点 – 2018年11月26日
https://help.sakura.ad.jp/notification/360000190121

FreeBSD 9.1 は 2014でサポート終了していますね。

FreeBSD 9.1-RELEASE
リリース 2012 年12月30日
サポート終了 2014年12月31日

サポートが終了したリリース
https://www.freebsd.org/ja/security/unsupported

さくらのレンタルサーバで利用しているOS「FreeBSD」のバージョンが古いため不安になっている方もいらっしゃるかもしれません。
OSが古くてもセキュリティパッチなどは自社で対応しておりますのでご安心ください。
また、2022年2月16日以降に契約された場合はFreeBSD13を提供しています。

さくらのレンタルサーバにまつわる噂に答えます!
https://rs.sakura.ad.jp/column/rs/rental-server-rumor

とはいえ、2015年2月5日がパッチの提供日の最終日となっていますが。。。

2017年2月さくらのレンタルサーバOS FreeBSD 9 古い!!
https://okamerin.com/nc/title/627.htm

PHP更新

以下の方法を参考に、無事 PHP 8系 に切り替えることができました。

【さくらのレンタルサーバ】PHPバージョンを切り替える方法 2021年11月30日
https://webst8.com/blog/sakura-php-version-setting

$ php -v
PHP 8.0.12 (cli) (built: Nov 11 2021 14:00:45) ( NTS )

PHP 8系にしたら、wordpressの動画が気持ち早くなったような気がします!

サーバー世代

さくらのレンタルサーバーには世代があります。

第3世代 2022年2月16日 以降に開設した環境
第2世代 2018年4月18日〜2022年2月15日 に開設した環境
第1世代 2018年4月17日 以前に開設した環境

私は2016年11月に契約したので、第1世代ですね。

以下のように新サーバーに移行しないと永遠に FreeBSD 9.1 のままかもしれません笑

新サーバー

2022年2月16日に新サーバー(第3世代)リリースがされました。

SSD化をはじめとした機材の刷新により、当社従来サーバーと比較して5倍の高速化を実現

New さくらのレンタルサーバ
https://www.sakura.ne.jp/speedup/?utm_source=newsletter&utm_medium=email&utm_campaign=20220218

引越しツールが近々リリースされるそうなので、freebsd 9 で古い、やばいと思ってる人は移行してみると良いですね。

引越しツールを使わなくても自動的に徐々に移行してくれそうなので、何もしなくても大丈夫かと思います。

それがいつになるのかはわかりませんが笑

コメント

タイトルとURLをコピーしました